Android Versions?

Tablets / Phones / Consoles / Ouya

Moderator: ezraanderson

Android Versions?

Postby ldeffenb » Wed Nov 09, 2016 2:49 pm

I'm building an app with MOAI and have found that it doesn't load on Android 4.0.4. Works fine on later versions, but on two different 4.0.4 platforms, it just displays a blank screen and Android eventually says that the app is not responding.

I've watched it in adb and the only thing the app says is that it is loading the shared library.

Does anyone have more recent MOAI versions working on 4.0.4 or earlier Androids?
ldeffenb
 
Posts: 10
Joined: Fri Jul 12, 2013 5:13 am

Re: Android Versions?

Postby halfnelson » Thu Nov 10, 2016 12:03 am

Maybe the .so build has the wrong target API and is targeting api 16 not 15
https://developer.android.com/ndk/guide ... _apis.html

Look for TARGET_PLATFORM := in android.mk
halfnelson
 
Posts: 710
Joined: Wed Jun 13, 2012 9:48 pm

Re: Android Versions?

Postby kodiaddons » Wed Jan 10, 2018 10:30 pm

yeah i also have the same issue, because of this targeting error
https://crumbles.co/kodi-download/
kodiaddons
 
Posts: 1
Joined: Wed Jan 10, 2018 10:26 pm


Return to Android

Who is online

Users browsing this forum: No registered users and 0 guests

cron

x