Layering Problems with OSX/iOS

iPhone / iPad / OSX / xcode

Moderators: ezraanderson, nosheet

Layering Problems with OSX/iOS

Postby naturally » Wed Sep 13, 2017 2:58 pm

Both platforms behave identically in a problematic way:

- Adding a layer with large transparent image over top of other layers doesn't work (image only shows after rgba alpha goes to like under 0.5 or so)
- Scissor rects don't work at all when over-layered
- Shadows are nightmarish to get working, need separate layer just for them, and can't use BLEND_MULTIPLY
- Have to use hacks and tricks to get sprites underneath shadow layers to show up (hard to explain, but, can't use same texture on two layers separate by a shadow layer, have to load two separate copies of the same texture)

What's the deal with all these glitches? Is there something I'm missing for using layers on Apple platforms? I have no troubles at all on Android, Windows, Linux.
Image - Don't Be Patchman - a sneak-and-grow adventure!
User avatar
naturally
 
Posts: 710
Joined: Thu Aug 29, 2013 8:05 pm
Location: Canada

Re: Layering Problems with OSX/iOS

Postby halfnelson » Wed Sep 13, 2017 4:07 pm

have you got a minimum reproducible example we can use to help test?
halfnelson
 
Posts: 708
Joined: Wed Jun 13, 2012 9:48 pm

Re: Layering Problems with OSX/iOS

Postby naturally » Wed Sep 13, 2017 7:16 pm

Definitely a good idea. I plan to do that now.

In the meantime someone might already know about one or more of these issues... :oops:
Image - Don't Be Patchman - a sneak-and-grow adventure!
User avatar
naturally
 
Posts: 710
Joined: Thu Aug 29, 2013 8:05 pm
Location: Canada


Return to Apple

Who is online

Users browsing this forum: No registered users and 0 guests

cron

x