Building MOAI 1.5 SDL on Ubuntu 16.04

64 bit / 32 bit desktops

Moderators: ezraanderson, spacepluk

Building MOAI 1.5 SDL on Ubuntu 16.04

Postby naturally » Wed Dec 21, 2016 8:59 am

This is a special case I'm sure very few if any people will need it, but...

With SDL 2.0.4 and Ubuntu 16.04 I had troubles building MOAI 1.5 SDL host with SDL v 2.0.4

I added this to the cmake/host-sdl/CMakeLists.txt
Code: Select all
  1. target_link_libraries ( moai

  2.         Xrandr

  3.         Xrender

  4.         Xi

  5.         GL

  6.         m

  7.         pthread

  8.         dl

  9.         drm

  10.         Xdamage

  11.         Xfixes

  12.         X11-xcb

  13.         xcb-glx

  14.         xcb-dri2

  15.         Xxf86vm

  16.         Xext

  17.         X11

  18.         pthread

  19.         xcb

  20.         Xau

  21.         Xdmcp

  22. )



As well as installing these extra packages: libxcb-util0-dev libsdl2-dev

You would have had to follow the SDL 2.0.4 install before this. :ugeek:
Image - Don't Be Patchman - a sneak-and-grow adventure!
User avatar
naturally
 
Posts: 689
Joined: Thu Aug 29, 2013 8:05 pm
Location: Canada

Return to Linux

Who is online

Users browsing this forum: No registered users and 1 guest

cron

x